Vectornator Crashing when using Pen Tool

Hello, I was contacting you all because my copy of Vectornator is crashing every time I try to use the pen tool. I can’t get even a single node created before it crashes. Any thoughts on what to do? I’ve updated it, tried resetting my iPad Pro, tried deleting as many design files as i can if it’s a space issue, etc. I would delete it and reinstall but I’m worried I would lose the design files I have saved. Please let me know if you have any thoughts. Thank you kindly.

Hi @EvanAyres and welcome to Vectornator Forum. Have you the last version 4.6? Have you tried to open a new project?

Hi @EvanAyres,

welcome to the Vectornator Forum and thanks for sharing your issue with us.

Does this behavior happen in every Vectornator file or just in one specific?

If it happens in only one specific file it is related to this file and a crash report of the file would be very helpful for us to better understand the problem. Once the application on iOS or macOS crashes, it’ll automatically create an .ips file containing details about this crash.

Here’s how you can find this file:

iOS: go to iPad/iPhone Settings → Privacy → Analytics&Improvements → Analytics Data → scroll down to see crash reports named Vectornator-202.-…-… . → provide us with this .ips file.

macOS: In the Finder, go to your Applications folder, then Utilities and launch the Console app. Select Crash Reports, find the Vectornator process and select it. Control-click it and press “Reveal in Finder” from the shortcut menu. Copy or drag out the selected report and attach it to the Forum post.

You can attach the file here or send us the crash report to our support email

Thank you very much!

I’m having the same issue. I did the online tutorial for making an isometric popsicle and everything worked great. Now whenever I go to use the pen tool using the Apple Pencil or my finger, the app crashes. I’ve rebooted my iPad Pro 11 (3Rd gen) and uninstalled and reinstalled Vectornator and the problem persists. Note that sometimes it works- but after a few times it crashes, so it’s not consistent.
Vectornator-2022-03-04-193102.ips (23.0 KB)

Vectornator-2022-03-05-103626.ips (20.8 KB)
Vectornator-2022-03-05-103937.ips (19.7 KB)
Vectornator-2022-03-05-110020.ips (19.3 KB)
Vectornator-2022-03-05-103655.ips (17.3 KB)

Hey guys!

Thank you so much for reporting this issue. I have already forwarded all the information to the team so that we can start investigating it.

@woodcreeper Can you confirm that this crash reproduces regardless of which file you are working with? And if it happens in only one specific file, can we ask to share it with us?
Thanks in advance.

Thank you @Oksana. It does indeed happen with any file.

1 Like