Vectornator on Mac started crashing

I have been using Vectornator for a few weeks now and I’m loving it! Thank you so much!
Recently though I’m having issues, with the whole program slowing down and making it very stressful selecting many objects at the same time, as well as moving things around in general.
In addition I’ve been having issues all along, it is very slow at opening the font selection, and the scrolling is very glitchy (probably due to the many fonts that I have installed in my computer)

1 Like

BUG #1

Hello, just flagging that the last 3 versions on iPad (latest being 4.5.1) have noticeable crashing issues. The effect is that for no reason the app crashes but instead of being frozen with no other resolution but to quit and restart, the app simply shuts down.

The impact is that the current last work on the tool selected is not saved. Vectornator does a great job trying to keep the work saved but more often that not, it is not able to save up to the last minute and in some instances there is a 2-5 min work completely gone due to this issue.

This bug has increased in periodicity from 3-4 times per hour to 3 times per 30 minutes over the last 3 versions.

BUG #2

Unsure if this other bug is related to it (also last 3 versions) the history/undo function has started to fail in recovering last step when undo is selected. Instead undo goes back several steps at once. This history cueing issue would not be a problem if we could control the process with undo and redo taps, however, the issue is that once the undo goes back a few steps, pressing redo in some cases deletes the history of those three steps at once so a lot of work is gone.

I have tested the above bugs with a clean restarted iPad Pro, and with no other app loaded in case it was a memory issue. Unfortunately the crashing issue is completely random. The undo/redo issue is also random.

I decided to create an account and post the bugs because I believe Vectornator is a remarkable, beautiful, valuable, interactive, fun and simple to use app that deserves feedback to make it even better. It is unbelievable that Vectornator is free and I thank you team for this awesome tool. The above bugs present a reliability risk and this could become a potential major issue - nobody likes loosing a lot of work :wink:

I confirm that I am a heavy user, 6-12 hours a day. I use it on an iPad Pro A1980.

I will be posting feature suggestions soon as well as doing my best to help the awesome Vectornator team with feedback.

Hi @Shazak and @nyx,

Thanks for taking the time to report these issues, I will pass all the information on to our QA team. We will continue to work on the stability improvements.

I would appreciate it if you can check if you received any crash reports after this happened.
iOS: go to iPad SettingsPrivacyAnalytics&ImprovementsAnalytics Datascroll down to see crash reports named Vectornator-2021-12-… . In case you received one, please email this .ips file to us.
macOS: open Console app → Crash Reports → Find Vectornator process and send us those files archived (can be any text document).
Please feel free to attach reports here. Or you can email us at with a link to this Forum post.

More details about your environment (device, OS version and app version), any videos of the issues can also be helpful.

Looking forward to hearing from you.

Warmest regards,

Hey @nyx,

Regarding BUG #2. I tried to reproduce it on my side, but no luck, the Undo feature works as expected. So I have to ask for your help.
Did you by any chance notice any steps that might help us reproduce this issue? They can really speed up our investigation.

Hi there Oksana,

Apologies for the delay and thanks so much for following up on this :slight_smile:

Most of my workflow happens using the selection, direct selection, scissors and pen tools; the bug is related to the combination of these tools.

In particular I noticed that the undo issue happened when I followed this workflow:

  1. copy path/s from layer A to layer B

  2. in some cases the paths are combined, others the paths are grouped

  3. if the paths are grouped I ungroup them and without deselecting them I combine them

  4. without deselecting I turn on the multi select mode

  5. I select other paths in the same layer

  6. I apply booleans between the selection

If I made a mistake and the paths are in the wrong stacking order I select the one that needs adjustment then send it to the very back or the very front. I then reselect and reapply boolean. Sometimes I need to do this deselection/selection/stackking order moving a few times, sometimes not.

At any poing within this workflow I may need to undo and/or redo. For some reason the undo queue does not work and suddenly: (a) the last steps are deleted, or (b) the last step only is deleted, or (c) the undo sends me way back, maybe before I even selected the last tool (in this case the undo arrow is also disabled so I cannot move forward).

Over the last 3 days or so this has happened from memory 3-4 times. Unfortunately it happens randomly, however, I recall the above steps clearly as I now have the habit of clossing Vectornator and reopen it again everytime I feel it may do it again or when I feel I have done a lot of complicated work that I need to protect.

I really hope this helps, I wish there was I way of capturing it. Please don’t hesitate to contact me if there is anything else that i can do to help or clarify questions

Cheers, Nyx

Hey @Shazak ,

May I ask you to provide us with one of your files where this issue appeared so that I can share it with our devs? Please feel free to attach it here. Or you can write us an email to mentioning a link to this Forum post and provide us with this file.
More information about your macOS device, OS version, Vectornator version, any videos of the issue might also be helpful in reproducing this issue.

Thanks for your help🙏

Thank you @nyx for providing us with detailed information about the Undo issue. I have passed all the info to our QA team already. We will do our best to get to the core of this issue and to fix it.
Please stay tuned!


Hi @Oksana ,

Sorry for the late reply,
I tried to attach the file but it wasn’t letting me, saying “not an authorized file”, although it is a Vectonator file. :man_shrugging:

I sent an email to the above mentioned address with the file attached. as well as all the info as in device info as well as Vectonator version.

Thank you very much!

1 Like

Hi everyone, att @Oksana
As @Shazak mentioned I have similarly experienced more crashes recently (iPad). And more problematically, it seems that lately a lot of the recent activities are not saved. I will be emailing some crash reports via email.

1 Like

Hi guys,

While we are solving this issue, we have a workaround that we recommend you try to solve the application’s slowdown. If you have any Snapping setting enabled, please disable it. This may solve the problem.

Warmest regards,

I’ve tried doing that and it still isn’t working as you can see in this clip.


Hi @Shazak,

I’m very sorry this workaround didn’t help. Our team is working on solving it! I will keep you posted as soon as I have an update.
We appreciate your patience.



Thank you so much!

Hi @Oksana
I am pretty sure that I was working without any snaps turned on when I experienced the crashes ass well. :crossed_fingers:t4: For a speedy bug fix.

1 Like

Hey folks,

I hope you’re doing well.
May I ask what you think of the latest version of Vectornator? We’ve done some refactoring and really hope those crashes don’t bother you anymore. We would really appreciate it if you can check it and let us know if you still experience the same issue.

@nyx, regarding the Undo issue, can we ask if it still reproduces in v4.5.2? If yes, could you provide us with a test file where you encountered this issue? We are still investigating this problem, unfortunately it’s not happening on our end so the file can help us reproduce it.

Thanks :relaxed:

Hi @Oksana ,

I’m still experiencing lag (not as much as before, but still uncomfortable).
It could be, just because of the amount of art-boards there are in the file, as well as the amount of shapes in that specific art-board (because when I delete that art-board the problem is not as noticeable.



Thanks for your feedback. I will inform our development team and we will continue to work on improvements.

1 Like

Same here please