macOS Vectornator crashing when clicking on "Library"

Good day everybody,

this is what I do to kill the application

  • starting Vectornator
  • clicking on “new document”
  • selecting A4 (doesn’t make a difference)
  • clicking on the “+” icon to access the Library
    ==> Beachball of Death
    ALT+CMD+ESC shows “Vectornator not responding”

my system:
Vectornator 4.5.3 (769)
macOS 12.2
Mac mini M1 (2020), 8GB

Any idea, what I could do? How do I completely remove all of Vectornator from my computer? Maybe starting all over / fresh install would help ?!?

Do you need any logs?

Thanks for your support!

Hey @bearking,

Thank you so much for reporting this problem.
Unfortunately, I cannot reproduce this crash on my device :pensive:
Can I ask you to check if you received any crash logs after this happened so that I can pass them on to the Dev team? To find crash reports open Console app → Crash Reports → Find Vectornator process and send us those files archived (can be any text document).
Thanks for your help!


1 Like

Hi Oksana,

since there was no crash report, i tried one more time. The beach ball was spinning again. I waited and waited. I left the computer and returned after quite some time… and voila! The library dialogue was visible! Icons, Unsplash, all accessible. I selected the “Vorlagen” tab and left the dialogue. Then again I clicked on “Library”. And there it is again, the beach ball. after 30 Minutes I give up and kill the application… :-(. If i figure something out, I’ll post again.

Hey @bearking,

There’s still something which can be done.

Next time the app spins do the following:

  1. Open the Activity Monitor (Aktivitätsanzeige)
  2. Search for the Vectornator process and select it in the list
  3. Click on the Info button and select “Analyse” in the info window
  4. Save the resulting file and send it over

This should give some insights into what the problem might be.

1 Like

Hi Oksana,

the Photos Library seems to be the problem. Looking at the console Vectornator hangs the moment it tries to communicate with Photos. I launched the Photos App and it tries to restore the library. This also takes FOR EVER. So i guess thats where the problem is.

conclusion: not a problem with Vectornator but with the Photos App / Library

Thanks for your patience and help!


thanks for the awesome information.

Photos was dead. Had to delete the whole Library (impatience won) and create a new one. Setting the new Library to System Default might also have helped. Now Photos and Vectornator are responding als expected Yippee!

Happy weekend!

1 Like

Glad to hear the issue is solved :man_dancing: :tada:

Have a great weekend!

thanks my issue has been fixed.