White background on canvas is on default and I'm not able to change it.


I’m not able to change the white background on the canvas to transparent. I use Vectornator on my Mac and it used to have the option to disable the white background when you click the “View” but now it’s gone. I also tried to check from the settings → Canvas, but there’s nothing about the white background there.

What would be the solution for this?


Hi there @PAPADON,

It is possible to remove the background colour and toggle on Transparency during export to PNG or SVG formats, however, it is not possible to enable transparency on your active Artboard while working on it.

If you would like us to introduce this feature, I recommend posting the suggestion to our Ideas & Feedback forum so that we can gauge user interest in the topic.


This is a feature that did exist and is now no longer an option, but certainly was available in previous version. In fact, your own site makes reference to it in the “learn” pages (Settings | Vectornator Learn Mac). I should be able to go to the top menu bar, select the view menu and toggle “White Background” to remove the default background WHILE working on a project. Was the option intentionally removed from the view menu? Removing this option is an inconvenience, especially when working on a piece with white fills.



I too am having the same issue.

I want to create my vector in white so that it exports in white for the purposes of DTF printing.

I’ve been using Vectornator for a while now and this was an option. This is the first time I’ve had to produce something completely in white for a while. I suppose I could get round it as you describe above, but I’d have to work in a colour and white out the each layer before saving.

Is there a better option?