I Have to restart to get back full functionality (Mac)

I occasionally (at least once per session) have to save and restart Vectonator to get the program back to functioning correctly.

  • Cannot select an item nor can I see the bounding box and handles to resize
  • Selecting and moving text is jerky and unreliable.
    Once I restart everything is back to normal. I cannot duplicate this issue it just sporadically happens, the file is simple with shapes and text.

Macbook Pro M1 Max, fully up to date

Hi there @Speacock110,

Next time this occurs, would you mind catching a screen recording so we can better understand the issue?

In the meantime, could you let me know whether this impacts all files or just one? Also, is this a new occurrence since the latest update (4.8.4) or was it happening for you prior to this version?


It has happened about 5 times on two completely different files. Sometimes twice in the same editing session.

Not sure about just the last version as I am reasonably new to Vectinator. I think the first time I noticed it was about two weeks ago. I update apps as soon as they become active updates.

Hey @Speacock110,

If this was first noticed two weeks ago that may have been just before our latest update, would you mind checking if you’re using Version 4.8.4 and if not, updating to it and letting me know if the issue persists? :slight_smile:


As I said I am always up to date and it only may have been about two weeks ago.

I checked just in case I missed one and I have version 4.8.4

Thank you for checking!

Next time the selection or moving issues occur for you, if you could capture a screen recording that would be extremely helpful. In the meantime, I will pass the current information over to the team for investigation.


Ok, will do, typical of this type of fault. Trying to make it happen, does not work

It happened again, I have recorded a video of me trying to select, transform etc. The only thing that would change is the stroke and fill. Note Option Scroll wheel would not zoom either. This fault occurred as I was working with Smart guides to confirm an accuracy issue, will I will log in later after I have experimented more. But in a nutshell just in case it is linked to the fault I and reporting. The bottom square is 100x50, when i try to use smart guides to make the red square the same width using smart guides it comes out slightly bigger, even with zero stroke width

I just restarted Vectornator twice to record a video about the Smart Guides issue and noticed that the Guides were not appearing as an object aligned to another (checked in the view menu and they were on,) and the partial display freeze happened however this time slightly differently. See the video below. Thinking about what I was doing previously when I had this fault I was using the Smart Guides all the time as I was creating an instruction document. The Mouse movement is actually a click and drag to move the object, which only moves when I release the mouse button

I am attaching the file as it may be faulty, as the issue occurs now almost as soon as I open it. I tried another file with just two rectangles and the Smart Guides worked as expected (except when dragging side handles the object locked to the reference rectangle but no smart guides were visible, smart guides only checked no snapping) and the sizes shown in the data entry section were identical, but not so on the attached file. Please note this is the third file the freeze has occasionally
Test Filer.vectornator.zip (22.4 KB)
happened on.

Hi there,

Thank you for providing the supporting footage and files. Upon initial review, we have been unable to reproduce these issues using your file. We will of course still look into the matter, but wanted to ask if you have an additional device that supports Vectornator, could you please attempt to reproduce this from your side also?

Additionally, if you could please forward the Diagnostic Files for the document: Open file in Vectornator → Upper toolbar ‘Help’ → Export diagnostic files

Kind regards,