Duplicate function doesn't work when within editor

Steps to reproduce:

  1. Create a new document, or enter an existing one.
  2. Try and duplicate the document while editing it.
  3. Note that nothing happens, and you’re now unable to exit the current document.

I can upload a screen recording if QA is unable to reproduce this.

Hi @llui85 please share with us the screen recording.


Hey @llui85,

Thanks for reporting this issue.
I’ve tried duplicating the document with a split view activated, tried duplicating the artboard from the Layers tab and using the Copy/Paste buttons.

I would appreciate it if you could provide us with a video of the problem.

1 Like

Sure, here’s a screen recording:

I’m using a 6th generation iPad running iOS 15.4

1 Like

Hi @llui85 thank you for screen recording. I replicated the procedure and it works on my iPhone. On my iPhone I am using the beta version 4.7.0. Anyway I suggest you to update vectornator to last version 4.6.4.

I updated to 4.6.4 this morning, and the issue still occurs (in fact it was using 4.6.4 when I recorded the video). I’d prefer not to use the beta, as it can’t be installed alongside the stable version, and this is my only device.

1 Like

No I didn’t suggest you to use beta version. I wanted to say that in the future version this bug was fixed. However I just downloaded the 4.6.4 version on my iPhone and it woks.

I’m sorry I didn’t help you.

Hi @llui85,
I’ve tried to reproduce this issue now on multiple devices, however was unable to. The current file is always duplicated. Two questions I have:

  • If you force-quit the app, can you still reproduce this issue?
  • After you restarted the app, are the expected duplicated files present?