Leaving old text on screen when making changes

M2 Pro MacBook Pro running Sonoma 14.1

Since the update when I try and make any changes to text it leaves the original text on screen so I can’t see what is being changed. Eg Changing spacing between letters and even changing the font. The pre change text stays there so I can’t see what I’m changing properly. Makes it pretty unusable. Any planned fix in the pipeline?

Hey @Mr_Conky I’m very sorry to hear you’re facing this issue. In order for us to be able to take a deeper look and see if we can solve this for you, would you be willing to send us the affected file?

Hi Medet.

Thank you for getting back to me. It is happening before I have saved the file. Here are the steps.

  1. Open a new document.
    2.Put in a text box and type something.
  2. Change the font or change the spacing and the issue is there, as per the screenshots.

If I click on the layer 1 icon on the left of the screen it goes away but the problem is that you can’t see what you are doing when you are making changes to the text. eg, changing the spacing.

I have uploaded a video of the issue (Compressed to keep the file size down but you can see the issue easily enough)

Thank you for your help.

Here is a save file, if that helps
Testing.curve (10.2 KB)

hey thanks for all the details and for sending us the file. I was not able to reproduce the issue with or without your file. Can you please confirm that this issue is happening to any found or just to a specific one?

Hi Igor.

It is happening with every document that I create. I have also tried it on a 5 year old Intel based MacBook Air and I am getting the same issue. They both worked fine before the update.


Hey @Mr_Conky

Thank you so much for all the info! The team is now investigating it and I’m hopeful we can get back to you with a concrete update on the matter.

Thank you once again!