Trouble with scrolling/selecting in Curve on Ventura/Intel

On my 2017 iMac running Ventura 13.5, I’m running into 2 big issues.

  1. I can’t scroll my document with any of the 3 input devices connected—Magic Mouse, Magic Trackpad, or Logitech Lift vertical mouse

  2. I can’t select multiple objects in the Layers Panel (the left side of the window that shows a hierarchical view of artboards/layers/groups/objects). When I try, using either Command or Shift, it’ll briefly highlight everything I intended to select, but then it’ll just switch to selecting one.

I have neither of these problems on an M1 Mac mini running Ventura or a 2019 Intel MacBook Pro running Sonoma beta. On the iMac, I tried creating a new user account. The second problem (selecting in the Layers Panel) was solved, but I still couldn’t scroll. I’ve removed the Logi Options+ software that came with my mouse, and it didn’t fix anything.

Any suggestions? Anyone else encounter these issues? They make it really difficult to work in Curve on my iMac, but it’s my biggest screen and most ergonomic setup!

1 Like

Hi @yonatron thank you for flagging these issues and I’m sorry it’s getting in your way.

This will require some further internal investigation on our end but our initial assumption could be around the operating systems and their compatibility regarding external devices. In any case, we have this on our radar and hope the team will be able to pick it up soon.

Thanks. Feel free to DM or email me if you need add’l details or want me to try any other troubleshooting steps. I was using Curve on the iMac today and was briefly able to multi-select objects in the Layers Panel, but have no idea what I was doing differently. Can’t seem to bring that functionality back now, on what I think was the same file.

Hi there,

Not sure if it was an update to Curve or Ventura, but in the past few days both issues seem to be resolved. Makes the app hugely more pleasant to use!

1 Like