Rubber tool does not create new shape

As in scissor and rubber tool videos described, I tried to cut shape into two. Even though visually I get two new closed vector shapes, it remains one element in the layer. I tried it with a simple circle too, and the bug is still there, just like with a more complicated shape

Hi there @hargitaisoma,

As Vectornator is continuously evolving and improving, some of our learning materials can become slightly outdated by showing examples of previous UI or describing tools whose functionality has since been updated. Our Education Team is always working on getting such content up to date but unfortunately it appears that you have come across examples of said older material.

We recently adjusted the Eraser Tool whereby splitting an element with the Eraser will result in a compound path and it is not possible to select subpaths of a compound path with the Selection Tool. The reason for this was that allowing the selection of subpaths of a compound path in this manner would result in unintuitive and inconsistent behaviour.

Here are some options for handling subpaths:

  • After using the Eraser Tool, use the Separate function on the subpath to divide it.

  • Use the Node Tool to manually select all the nodes of an element that resulted from the Eraser Tool and move the element.

  • As a shortcut for the above, activate the Node Tool → hold ⌘ → select one node in your desired element → all nodes will be selected → the element can now be freely moved.

  • Use the Scissors Tool for the splitting of paths.

Hope this helps,