Grid functions do not work in MacOS

Setting grid spacing does not work. Snap to grid does not work.
I have View>Units set to mm.
Trying to set grid spacing to 5mm, and it jumps to 18965.6 mm and cannot be reset.
This is ridiculous. I searched the forum and this bug has persisted for over a year.
This program is unusable. I’m disappointed that I paid money for this.

Hey @Chris_Lee , I’m sorry to hear about the issues you’re experiencing. If you add the desired value and click Enter, the changes should save. We understand that this is just a workaround, and I apologize for the inconvenience. I will raise this with the developers to see if we can prioritize this.

Thank you for your patience, and we appreciate your feedback.

Yes, that’s the first thing I tried and it does not work. The value does not change or save.

That’s indeed strange, as I tried it on my device and it worked with the workaround. Apologize for the experience. Could you please send us a screen recording? Also, could you provide more details about your Linearity Curve version and your device’s OS version? This will help us troubleshoot the problem better. Thanks!