Disable Apple Pencil double-tap

It is really annoying that I always undo something accidentally because the pencil interprets just holding it as a double-tap. A simple “none” option would be awesome.

1 Like

I apologise in advance as I suspect you already know this but, as a workaround, you can turn off the double tap globally (across all apps).

1 Like

I cannot agree more @vectornator_user, I find the side button really inconvenient and never use it with Vectornator. Unfortunately within Vectornator I can only set the side button to either redo or undo or activate last used tool when what I really need is to turn that button off.

@ButlerToCats, turning the button off does not help as the buttons are reprogrammed inside Vectornator which seems to override the global setting? Is this working for you?

I wish the Vectornator team added a “None” option for those not interested in the side button. Would this be possible team?


Hey Vectornator team, I figure you guys must be busy with surely much more important work and I wouldn’t raise it again if it wasn’t driving me nuts.

Like many other Vectornator users who don’t use the pencil double tap in their workflow I have learned to work around this as currently there is no way to turn the double tap off. However it is really slowing me down and causing issues, namely losing work or making constant mistakes.

I am either experiencing unexpected undo or redo, changes of my selected tool to the last used tool that I definitely don’t need, or even more dangerous when I accidentally delete work without even noticing in case I setup the double tap to delete.

I find that I have to correct a lot of work because this button remains on. I’m not sure how complex would it be to add a ‘turn pencil double tap off’ in the preferences as one more option in that menu; if it is not very complex, could you please add this button for all the users who like me are desperate trying to work with the pencil like this?

We will be eternally grateful, please :face_with_raised_eyebrow:

I found a fix… or, well, a workaround - but it works!

Go to device settings > accessibility > Apple Pencil and turn double tap gesture off.
NOTE: The Apple Pencil settings will only appear in accessibility if you are navigating the menu with the Apple Pencil, so keep that in mind.

For me, Vectornator was overriding my double tap settings. Despite it being turned off in device settings it would still register double taps and was the only app that appeared to be doing this. Annoying, but the fix above did the trick!

Devs, please add a “none” option for Apple Pencil gestures as some may want to continue using double tap in other apps.