Changes on the document won't save or export (iPad)

Whenever I edit a project on my iPad and try to save it so I won’t lose my progress it saves without any trouble. The problem is that when I open the saved file on my iPad or Mac after closing the app, the changes don’t appear on the saved document, so it’s like it was never saved.
I also tried exporting, but it’s the same problem.

I have lost hours of work due to this bug, please fix it. :frowning:

1 Like

Hi @chofas28,

Thanks for contacting us.
I’m sorry for asking so many questions, but it’s very important for us to understand step by step what actions you have taken so that we cat try to reproduce this issue on our side.
Did I understand correctly that you open the Vectornator file by tapping on it in the Gallery screen? Then after editing this project, you save it. Can I ask what format you usually choose to save the files (.vectornator, .svg, etc)? Please let us know if you initially imported a file with a different format (.svg, .ai, etc.) into Vectornator, this can be a very important step.

Can we also ask how you later open this project? Do you click on it in the Vectornator gallery? Or maybe you open that file from the Files app?
Any videos with this issue captured might be very helpful.
Thanks :pray:

Warmest regards,

Hi, Oksana.
Thanks for assisting me.
Yeah, whenever I create a new Vectornator file or open a saved one on my iPad (from my files or directly from the Vectornator file gallery) I edit the project, and I save it. I always save it with the .vectornator format, and sometimes I export it as PDF in order to have a backup.
But when I open the file I saved (from files or the Vectornator project gallery), on my Mac (or even on my iPad) it opens a project with less advanced progressed than the one I saved.

Once I noticed this in the preview on the exportation or saving window of my project, and I tried to export it as .svg, .png, .jpg, etc… but the changes were neither saved nor exported.

I don’t have any video at the moment becauseI have not used Vectornator lately due to this issue, but I’ll try to upload one.


Can I clarify one more thing? How often does this problem with loss of progress occur? Every time you save and close a document?
We would appreciate if you can provide us with a video of the issue so that I can forward it to the Dev team and ask for help. You can attach it here or upload it to and share the link with us.
Thanks :pray: