AI Export “Something Went Wrong”

Hey there, Export to Adobe Illustrator is not working on iPad using the [EXPORT] ‘Adobe Illustrator’ option. I tried with multiple files with no luck.

Vectornator shows a “Something went wrong with conversion” message then stays in infinite loop.

As an alternative I tried Exporting [CONTINUITY] ‘Send to Ilustrator CC’ with no luck either. I have Illustrator installed on the iPad but it does not receive anything from Vectornator. Contrary to the above scenario, with this option the CC logo appears with a progress bar at the bottom and after a few seconds a tick icon appears presumably showing than the export went ok; however, I did not find the AI export anywhere.

I also tried CONTINUITY ‘Creative Cloud’ hoping this would work; however, even though I have the Creative Cloud app installed and signed in, I cannot see any files coming from Vectornator.

As I was desperate and do need Vectornator to export extensive work I tried SVG and PDF and logically this meant losing groups, names, etc.

While the files got exported, there are a few issues with the exporting process namely the masks don’t get exported so I had to go back to Vectornator and convert all masks with booleans and groups. Had I known this I would have done things very differently.

I’m very surprised with this export issue as AI export seemed to work effortless and presumably seamless.

I have not seen any topic related and can’t seem to make it work no matter how many times I tried, including taking files apart breaking them per layers and simplifying them to the minimum and still unsuccessful.

Could you please let me know if this is a known problem with workaround or how are we supposed to get Vectornator into AI seamlessly? I may be doing something wrong (I read all info in the forum about export to AI)


Hey @nyx,
We are doing our best to fix this issue as soon as possible and release an update in the next days. Sorry for the inconvenience.
Please stay tuned for the update.

Warmest regards,

Thanks @Oksana for letting me know


Hi @nyx,
I have some good news!
Happy to announce that this issue is fixed now. Please check out the latest 4.5.3 version.


Hey there @Oksana, just installed 4.5.3 and tried exporting to AI via [EXPORT] Adobe Illustrator. The error popped again and Vectornator stays in infinite loop until I tap cancel. Is there anything else I can do to export these files to AI?

One things is clear, exporting this way does not fail with every file. The files that fail are relatively quite simple, they all have around 16 layers and they are mostly made of paths and shapes with a few masks and some texts.

Could you please tell me what the issue was when you resolved the bug on your end? Or what it was related to so I can see if my files may be related? I also know that the files that I cannot export to AI have masks.

In one of my attempts to export one of these files to AI I managed to do it although I’m not sure how as I was trying a number of things. The resulting file once opened in AI showed these masks exported incorrectly ( shapes missing and the mask turned into black ).

To be able to get these layers with these masks into AI I had to turn all these masks into clean shapes using booleans, then delete every layer but the layer with the mask converted then export it to AI. It eventually exported though it also failed at times. From memory I think I also copied this new layer into a new doc then tried exporting. I’m just not sure what did work at the end for these single layers and was hoping you were able to fix the bug hence allowing me to export the file as a whole, perhaps with the masks working in AI.

Could you also guide me through the other [CONTINUITY] Send to Illustrator CC or Creative Cloud avenue on my iPad? When I tap these it seems to work. Perhaps I can make it happen this other way. I have illustrator and CC installed but am not sure how I’m supposed to access the files sent from Vectornator using these other options.

Thanks you very much for providing us with all these details on the issue.
I just checked many of my files that have masks and unfortunately I can’t catch this error anymore. Apparently it depends on the specific file. Can I ask to provide us with a test file so that I can forward it to the QA team? It might really speed up our investigation.
As for the [CONTINUITY] section, it works a bit differently. Pressing the “Send to Illustrator CC” button sends the project directly to Illustrator CC using the Cloud.


Export to AI is not working on iPad.

Symptoms as reported above.

I created an artboard with 1 simple vector shape. As with my other projects, Vectornator does not complete the background task and the export button remains greyed out.

Please help!


Hi there @whisperingjohn and welcome to the Vectornator community!

We’re currently experiencing a known issue within our ai exporting process which the team is investigating.

It would be extremely helpful if you could post a video demonstrating the problem in question.


Thanks for getting back to me, Helen.

Here is a link to a screen recording of the AI export issue on iPad pro with the latest version of Vectornator.

Good luck!


1 Like

Hey @whisperingjohn,

Good news, with our latest update you should find that this issue has been resolved :tada:

I recommend that you check out Vectornator version 4.8.5 which features a variety of other improvements and our exciting new Inner/Outer Stroke function.

If you notice any other issues or have any additional feedback, please don’t hesitate to reach out!